본문 바로가기

개발자/Android

안드로이드 스튜드오 실행 에러 INSTALL_FAILED_OLDER_SDK




안드로이드 스튜디오에서 가상 장치 AVD 가 아니라 실제 기기로 다운로드 하여 개발할때 아래와 같은 에러가 나온다.


Installation failed with message INSTALL_FAILED_OLDER_SDK.

It is possible that this issue is resolved by uninstalling an existing version of the apk if it is present, and then re-installing.


WARNING: Uninstalling will remove the application data!


Do you want to uninstall the existing application?


화면을 캡쳐하면 아래와 같다.



이런 INSTALL_FAILED_OLDER_SDK 에러는 최저 SDK 사양이 맞지 않아서 발생한다. 우선 

최저 SDK 사양에 맞는 SDK를 설치 하는데 Tools->Android->SDK Manager에서 SDK를 설치하고,

개발중인 프로젝트의 minSDK 버전을 변경해준다. 여기서는 minSDK 가 22 로 되어있고 갤럭시 3에 다운로드 하려니 위와 같은 에러가 계속 발생되었다.


아래와 같은 프로젝트 화면에서 



프로젝트 이름에서, 여기서는 app 에서 마우스 오른쪽 버튼을 눌러 메뉴에서 Open Module Setting 을 선택한다.





열리는 창에서 Flavors 탭을 클릭하여 Min Sdk Version 에 아래와 같이 API19 를 선택주고 빠져나오면 된다.




그러면 AndroidMenifesto.xml 파일은 아무 변화 가 없고,  Bulild Gradle(Module : App) 파일의 minsdk 버전이 22 에서 19로 바뀐다.



apply plugin: 'com.android.application'

android {
compileSdkVersion 22
buildToolsVersion "22.0.1"
defaultConfig {
applicationId "com.huins.androidsample"
minSdkVersion 19
targetSdkVersion 22
versionCode 1
versionName "1.0"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
productFlavors {
}
}

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
}

와 같이 변경하면 실제 안드로이드 기기에서 잘 실행될 것이다.

개발자의 공유는 삽질을 멈추게 한다.ㅎㅎ